読者です 読者をやめる 読者になる 読者になる

tjinjin's blog

いつかすごいエンジニアになることを目指して、日々学んだことを書いていきます。

Railstutorial学習記録3

今3章をやっています。

2章やっているときにいろいろエラーが出て、?と思っていましたが
3章でもエラー。

どうやら railsのバージョンが4.1.4になっていたようです。
(確かに昔、serverspec試すときにrails導入してたような気もします。)

グローバル領域のバージョンが4.1.4になっていたため、アプリをnewする
際に4.1.4として作成されてしまい、作成後にGemfileを4.0.5に直しても
うまくいかなかったようです。

いろいろ試行錯誤(rbenvでバージョン切り替え)しましたが、アプリ作成時に
バージョンを指定することで落ち着きました。

$ rails _4.0.5_ new sample_app

上記のように作成する際のバージョンを_x.x.x_で指定することが可能です。
バージョン管理はしっかりやらないと怖いですね。いい勉強になりました。